blob: 64dc32cb96264cb9df8787e8abde20660c075083 [file] [log] [blame]
SUMMARY = "Program for creating simple man pages"
SECTION = "devel"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "autoconf-native automake-native"
SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
SRC_URI[md5sum] = "544aca496a7d89de3e5d99e56a2f03d3"
SRC_URI[sha256sum] = "d4ecf697d13f14dd1a78c5995f06459bff706fd1ce593d1c02d81667c0207753"
inherit autotools native
EXTRA_OECONF = "--disable-nls"
# We don't want to reconfigure things as it would require 'perlnative' to be
# used.
do_configure() {
oe_runconf
}
do_install_append () {
# Make sure we use /usr/bin/env perl
sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
}