blob: 319acd3b4ee6f71192fee47a9e3311226bb20551 [file] [log] [blame]
SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
DESCRIPTION = "\
Pinentry is a collection of simple PIN or passphrase entry dialogs which \
utilize the Assuan protocol as described by the aegypten project; see \
http://www.gnupg.org/aegypten/ for details."
HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
inherit autotools pkgconfig
DEPENDS = "gettext-native libassuan libgpg-error"
UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
file://libassuan_pkgconf.patch \
file://gpg-error_pkconf.patch \
"
SRC_URI[md5sum] = "4a3fad8b31f9b4c5526c8837495015dc"
SRC_URI[sha256sum] = "1672c2edc1feb036075b187c0773787b2afd0544f55025c645a71b4c2f79275a"
EXTRA_OECONF = "--disable-rpath --disable-dependency-tracking \
--disable-pinentry-qt5 \
"
PACKAGECONFIG ??= "ncurses libcap"
PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qt4-x11"
PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
#To use libsecret, add meta-gnome
PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"