sdbusplus: use meson build

(From meta-phosphor rev: f9eed5e63cb16cf58ccfe14c953e42ba8a194403)

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ie6fb8b012b5750378f882794f0777e06778722aa
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index f102c7b..49e2f4a 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -1,9 +1,8 @@
 SUMMARY = "C++ bindings for systemd dbus APIs"
 DESCRIPTION = "C++ bindings for systemd dbus APIs."
 
-inherit autotools pkgconfig
-inherit obmc-phosphor-python3-autotools
-
+inherit meson
+inherit python3native
 include sdbusplus-rev.inc
 
 LICENSE = "Apache-2.0"
@@ -12,19 +11,10 @@
 S = "${WORKDIR}/git"
 
 DEPENDS += " \
-        autoconf-archive-native \
         ${PYTHON_PN}-inflection-native \
         ${PYTHON_PN}-mako-native \
         ${PYTHON_PN}-pyyaml-native \
+        boost \
+        googletest \
+        systemd \
         "
-
-PACKAGECONFIG ??= "libsdbusplus"
-PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
-
-# Remove unused sdbus++ contents (included in python3-sdbus++ package).
-do_install_append() {
-    rm ${D}/${bindir}/sdbus++
-    rmdir ${D}/${bindir} || true
-    rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}
-    rmdir ${D}/${libdir}/${PYTHON_DIR} || true
-}