meta-intel: Add intel-dbus-interfaces
This recipe is used for Intel specific features and IPMI OEM commands.
Tested By:
bitbake intel-dbus-interfaces
(From meta-intel rev: c5a33a96c6ae6eeaedc5d314c8497dc358eff589)
Change-Id: I0ce1a37d271fbe43612c75308b02068426a12e0b
Signed-off-by: Yong Li <yong.b.li@linux.intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
new file mode 100644
index 0000000..14214e0
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Intel DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbus++-native"
+
+SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
+SRCREV = "299018f99693771c175980315a3ee54f7abd7303"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libintel_dbus"
+PACKAGECONFIG[libintel_dbus] = " \
+ --enable-libintel_dbus, \
+ --disable-libintel_dbus, \
+ systemd sdbusplus, \
+ libsystemd sdbusplus \
+ "
+
+PACKAGECONFIG_remove_class-native = "libintel_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+
+BBCLASSEXTEND += "native nativesdk"
\ No newline at end of file