openpower: Add ASPEED LPC Control tool

This includes the 'pnorboot' tool for configuring the LPC firmware
mapping.

This is used by Palmetto instead of mboxd, as Palmetto only requires the
LPC mapping component. The mbox component causes interrupts to be
continually triggered on the host, causing unnecessary CPU load.

As Palmetto is the only in-tree user of this tool, the service file hard
codes the PNOR size. If we merge machines in the future this should be
configured by the machine layer.

Resolves: openbmc/openbmc#3357
Tested: Booted host on Palmetto, checked interrupt count
Change-Id: I87daafa5008e978afd3a5fc386b347b014624911
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb
new file mode 100644
index 0000000..f37f2be
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb
@@ -0,0 +1,15 @@
+SUMMARY = "ASPEED LPC Host Interface Control tool"
+DESCRIPTION = "Configures the BMC to expose memory regions to the host"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+inherit autotools
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} += "pnorboot.service"
+
+SRC_URI += "git://github.com/shenki/aspeed-lpc-control"
+SRCREV = "ab2012e749daf567049bf157c3bf037adc62c0e8"