meta-openembedded: refresh master: 0435c9e193..4a9deabbc8

Update meta-openembedded to master HEAD.

Alistair Francis (7):
      python3-pyaudio: Initial commit
      python3-pyfann2: Initial commit
      python3-pocketsphinx: Initial commit
      python3-xxhash: Initial commit
      mycroft: Initial commit
      libfann: Initial commit
      python-cryptography: Bump from 2.4.1 to 2.6.1

Andreas Müller (10):
      xfce4-screenshooter: upgrade 1.9.4 -> 1.9.5
      networkmanager: Fix upstream regex for 1.16
      networkmanager: fix build with musl
      gvfs: fix configure options and DDEPENDS
      rrdtool: fix build by disabling docs
      libpeas: rework gobject-introspection handling
      gvfs: Fix missing executable permission flags for files in libexec
      gnome-desktop3: remove gconf from DEPENDS
      gnome-desktop3: rework gobject-introspection handling
      gnome-desktop3: Disable libseccomp for all archs

Brad Bishop (1):
      libvncserver: enable split client/server packages

Fabio Berton (1):
      python*-requests: Update 2.20.1 -> 2.21.0

Gianfranco Costamagna (2):
      cpprest: fix build failure on 32bit systems, with upstream merged patch
      libmodbus: start to prefer version 3.1.4 as default

Hongxu Jia (1):
      dracut: fix udevdir not found

Khem Raj (5):
      ncmpc: Rename artist_screen to library_screen
      networkmanager: Fix build with clang
      alsa-oss: Upgrade to 1.1.8
      redis: Fix ocasional parallel build failure
      lcdproc: Fix parallel build

Nikolay Nizov (2):
      android-tools-conf: fix typo
      android-tools-conf: Make sure /dev/pts/0 exists

Oleksandr Kravchuk (2):
      fping: update to 4.2
      nuttcp: update to 7.3.3

Peter Kjellerstedt (1):
      doxygen: Make it build with ninja 1.9.0

Qi.Chen@windriver.com (2):
      openldap: add missing CVE tag to patch
      ipsec-tools: add missing CVE tags to patches

Randy MacLeod (2):
      imagemagic: upgrade to 7.0.8-35
      wolfssl: update to 3.15.8 and use github SRC_URI

Slater, Joseph (1):
      tcpreplay: update to version 4.3.2

Vincent Prince (4):
      Rsyslog: Add mmjsonparse to PACKAGECONFIG
      zeromq: bump version 4.2.5 => 4.3.1
      cppzmq: bump version 4.2.3 => 4.3.0
      czmq: bump version 4.1.1 => 4.2.0

Yi Zhao (3):
      python-engineio: add recipe
      python-socketio: add recipe
      python-flask-socketio

Zang Ruochen (4):
      augeas: upgrade 1.10.1 -> 1.11.0
      libedit: upgrade 20181209-3.1 -> 20190324-3.1
      mcelog: upgrade 161 -> 162
      lockfile-progs: upgrade 0.1.17 -> 0.1.18

leimaohui (1):
      Fix build error for armeb.

Change-Id: Ie79748c484bcf4fd28b3bde84e2194044e1c08a8
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.1.bb b/meta-openembedded/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.1.bb
new file mode 100644
index 0000000..6e13376
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "ZeroMQ looks like an embeddable networking library but acts like a concurrency framework"
+HOMEPAGE = "http://www.zeromq.org"
+LICENSE = "LGPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=d5311495d952062e0e4fbba39cbf3de1"
+
+PACKAGECONFIG ??= "libsodium"
+PACKAGECONFIG[libsodium] = "-DWITH_LIBSODIUM=ON,-DWITH_LIBSODIUM=OFF, libsodium"
+
+SRC_URI = "http://github.com/zeromq/libzmq/releases/download/v${PV}/zeromq-${PV}.tar.gz \
+    file://run-ptest \
+"
+SRC_URI[md5sum] = "64cbf3577afdbfda30358bc757a6ac83"
+SRC_URI[sha256sum] = "bcbabe1e2c7d0eec4ed612e10b94b112dd5f06fcefa994a0c79a45d835cd21eb"
+
+inherit cmake ptest pkgconfig
+
+EXTRA_OECMAKE = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DBUILD_TESTS=ON', '-DBUILD_TESTS=OFF', d)} \
+                 -DCMAKE_SKIP_RPATH=ON \
+"
+
+do_install_ptest () {
+    install -d ${D}${PTEST_PATH}/tests
+    install -m 0755 ${B}/bin/test_* ${D}${PTEST_PATH}/tests
+}
+
+FILES_${PN}-doc += "${datadir}/zmq/*.txt"