Power supply monitor recipe, service, and conf

Add the Witherspoon power supply monitor application, service file, and
configuration files to the witherspoon-pfault-analysis recipe.

Moved OBMC_POWER_SUPPLY_INSTANCES to the global metadata so it can be
shared between recipes.

Resolves: openbmc/openbmc#1731

Depends-On: Ie364a3dc5b7f19cbc587450fc54f231d1ec280f7

Change-Id: I340a1d48a979a97624843e59a5ab1b1ad04056bb
Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor.bbappend
index 9d1ca66..b60a64b 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor.bbappend
@@ -1,14 +1,12 @@
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 
-OBMC_POWERSUPPLY_INSTANCES = "0 1"
-
 TMPL_POWERSUPPLY = "phosphor-gpio-presence@.service"
 INSTFMT_POWERSUPPLY = "phosphor-gpio-presence@{0}.service"
 POWERSUPPLY_TGT = "${SYSTEMD_DEFAULT_TARGET}"
 FMT_POWERSUPPLY = "../${TMPL_POWERSUPPLY}:${POWERSUPPLY_TGT}.requires/${INSTFMT_POWERSUPPLY}"
 
-SYSTEMD_LINK_${PN}-presence += "${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWERSUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence += "${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
 
 POWERSUPPLY_ENV_FMT  = "obmc/gpio/phosphor-power-supply-{0}.conf"
 
-SYSTEMD_ENVIRONMENT_FILE_${PN}-presence += "${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWERSUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence += "${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"