meta-openembedded: subtree update:41fe46157c..e6d76b05a7

Adrian Bunk (1):
      networkmanager: Correct the upstream version check

Adrian Ratiu (1):
      renderdoc: add new recipe

Changqing Li (1):
      kea: upgrade 1.5.0 -> 1.7.0

Denys Dmytriyenko (1):
      rwmem: add recipe

Hongxu Jia (1):
      lvm2: fix run lvcreate hung while PACKAGECONFIG udev

Jackie Huang (6):
      python-versiontools: add recipes for python2 and python3
      python-pymysql: add recipes for python2 and python3
      python-statistics: add new recipe
      python-pyperf: add recipes for python2 and python3
      python-pika: add recipes for python2 and python3
      python-pycurl: add recipes for python2 and python3

Khem Raj (6):
      openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl
      ttf-gentium: Use OFL-1.0 version of OFL license
      ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file
      python-configparser: Mark license as MIT
      fontforge: Upgrade to 20190801 release
      opensaf: Fix duplicate copies of shared libs in package

Martin Jansa (2):
      spice: ignore all warnings not just address-of-packed-member
      Revert "spice: Drop broken native"

Otavio Salvador (5):
      networkmanager: Fix ADSL plugin packaging
      networkmanager: Add a `resolvconf` PACKAGECONFIG
      networkmanager: Add sysvinit support
      libqmi: Upgrade 1.22.2 -> 1.24.0
      modemmanager: Upgrade 1.10.0 -> 1.10.2

Qi.Chen@windriver.com (1):
      protobuf-c: fix race condition

Robert Yang (2):
      corosync: Fix PACKAGECONFIG flag for rdma
      net-snmp: Fix PACKAGECONFIG for perl

Zang Ruochen (1):
      python-urllib3: upgrade 1.25.5 -> 1.25.6

Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-networking/recipes-support/spice/spice_git.bb b/meta-openembedded/meta-networking/recipes-support/spice/spice_git.bb
index 30e939a..06a79c5 100644
--- a/meta-openembedded/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-openembedded/meta-networking/recipes-support/spice/spice_git.bb
@@ -37,8 +37,9 @@
 export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
 export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
 
-CFLAGS_append = " -Wno-error=address-of-packed-member"
+CFLAGS_append = " -Wno-error"
 
+PACKAGECONFIG_class-native = ""
 PACKAGECONFIG_class-nativesdk = ""
 PACKAGECONFIG ?= "sasl"
 
@@ -53,6 +54,6 @@
 
 COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
 
-BBCLASSEXTEND = "nativesdk"
+BBCLASSEXTEND = "native nativesdk"
 
 EXTRA_OECONF_append_toolchain-clang = " --disable-werror"