meta-openembedded: subtree update:41fe46157c..e6d76b05a7

Adrian Bunk (1):
      networkmanager: Correct the upstream version check

Adrian Ratiu (1):
      renderdoc: add new recipe

Changqing Li (1):
      kea: upgrade 1.5.0 -> 1.7.0

Denys Dmytriyenko (1):
      rwmem: add recipe

Hongxu Jia (1):
      lvm2: fix run lvcreate hung while PACKAGECONFIG udev

Jackie Huang (6):
      python-versiontools: add recipes for python2 and python3
      python-pymysql: add recipes for python2 and python3
      python-statistics: add new recipe
      python-pyperf: add recipes for python2 and python3
      python-pika: add recipes for python2 and python3
      python-pycurl: add recipes for python2 and python3

Khem Raj (6):
      openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl
      ttf-gentium: Use OFL-1.0 version of OFL license
      ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file
      python-configparser: Mark license as MIT
      fontforge: Upgrade to 20190801 release
      opensaf: Fix duplicate copies of shared libs in package

Martin Jansa (2):
      spice: ignore all warnings not just address-of-packed-member
      Revert "spice: Drop broken native"

Otavio Salvador (5):
      networkmanager: Fix ADSL plugin packaging
      networkmanager: Add a `resolvconf` PACKAGECONFIG
      networkmanager: Add sysvinit support
      libqmi: Upgrade 1.22.2 -> 1.24.0
      modemmanager: Upgrade 1.10.0 -> 1.10.2

Qi.Chen@windriver.com (1):
      protobuf-c: fix race condition

Robert Yang (2):
      corosync: Fix PACKAGECONFIG flag for rdma
      net-snmp: Fix PACKAGECONFIG for perl

Zang Ruochen (1):
      python-urllib3: upgrade 1.25.5 -> 1.25.6

Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
new file mode 100644
index 0000000..25c2ce8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -0,0 +1,46 @@
+SUMMARY = "A font editor"
+HOMEPAGE = "http://fontforge.github.io/en-US/"
+LICENSE = "BSD-3-Clause & GPLv3"
+LIC_FILES_CHKSUM = " \
+    file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
+    file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \
+"
+
+DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gettext-native"
+DEPENDS_append_class-target = " libxi"
+
+inherit autotools pkgconfig pythonnative distro_features_check gettext gtk-icon-cache mime
+
+REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
+
+# tag 20190801
+SRCREV = "ac635b818e38ddb8e7e2e1057330a32b4e25476e"
+SRC_URI = "git://github.com/${BPN}/${BPN}.git \
+           file://0001-include-sys-select-on-non-glibc-platforms.patch \
+"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--without-libuninameslist"
+EXTRA_OECONF_append_class-native = " with_x=no"
+
+#do_configure_prepend() {
+# uthash sources are expected in uthash/src
+#    mkdir -p ${S}/uthash/src
+#    cp ${STAGING_INCDIR}/ut*.h ${S}/uthash/src
+#}
+
+PACKAGES =+ "${PN}-python"
+
+RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
+
+FILES_${PN} += " \
+    ${datadir}/appdata \
+    ${datadir}/metainfo \
+    ${datadir}/mime \
+"
+
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
+RDEPENDS_${PN}-python = "python"
+
+# for e.g kde's oxygen-fonts
+BBCLASSEXTEND = "native"