meta-phosphor: dbus-interfaces: rename as git recipe

Rename phosphor-dbus-interfaces.bb to phosphor-dbus-interfaces_git.bb
per OE norms.

(From meta-phosphor rev: 8ded78fb91050700c4524c78df58074ec8b169cc)

Change-Id: I1c704da6006ab58a045d8f61608178a5c58f98f8
Signed-off-by: Patrick Venture <venture@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
new file mode 100644
index 0000000..b87ceb7
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Phosphor DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit pythonnative
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbus++-native"
+
+SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
+SRCREV = "c06f29ada4726864618c764ba767ff1c8c42758c"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libphosphor_dbus"
+PACKAGECONFIG[libphosphor_dbus] = " \
+        --enable-libphosphor_dbus, \
+        --disable-libphosphor_dbus, \
+        systemd sdbusplus, \
+        libsystemd sdbusplus \
+        "
+
+PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
+
+BBCLASSEXTEND += "native nativesdk"