meta-phosphor: ecc: add BMC ECC logging recipe

Add new recipe for monitoring BMC ECC UE/CE and logging

Design proposal:
https://gerrit.openbmc-project.xyz/c/openbmc/docs/+/18684

phosphor-ecc commit and test result:
https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-ecc/+/22562

(From meta-phosphor rev: e904d47c1c6146c11416984e1f89d1bf2f3c87ee)

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I21723a5279a7688ba4dec8698b6355e5d0a5c1a6
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/ecc/phosphor-ecc_git.bb b/meta-phosphor/recipes-phosphor/ecc/phosphor-ecc_git.bb
new file mode 100644
index 0000000..024ccae
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ecc/phosphor-ecc_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phosphor BMC Memory ECC Logging"
+DESCRIPTION = "Daemon to monitor and report the BMC memory ECC"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+PR = "r1"
+
+inherit meson pkgconfig
+inherit systemd
+
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-logging"
+
+RDEPENDS_${PN} += "phosphor-sel-logger"
+
+SRC_URI = "git://github.com/openbmc/phosphor-ecc.git"
+SRCREV = "a1d42027be51ac94b1b14b59f05797287e57d5b4"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = " ${PN}.service"