phosphor-dbus-interfaces: remove native support

The native and nativesdk packages for PDI were previously used as the
mechanism to install YAML files.  Within the image, the -native packages
are no longer used and instead there is a target -yaml package which
contains the YAML files.  As a follow up, we can now do the three items:

    * Remove nativesdk-PDI from SDK.
    * Add target PDI-yaml to the SDK.
    * Remove native/native-sdk support from PDI recipes.

(From meta-phosphor rev: 4f00c4b4504951324c78183a3ed6e8cbc8f2580c)

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ic049da4855df7e19225e7acd9eeb16efaa9808d1
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend b/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
index d62dc99..8327383 100644
--- a/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
+++ b/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
@@ -1 +1,7 @@
-RRECOMMENDS_${PN}_append = " googletest sdbusplus phosphor-logging libstdc++-staticdev"
+RRECOMMENDS_${PN}_append = " \
+    googletest \
+    libstdc++-staticdev \
+    phosphor-dbus-interfaces-yaml \
+    phosphor-logging \
+    sdbusplus \
+    "