poky: subtree update:a015ed7704..797916f93a

Adrian Bunk (4):
      poky-tiny.conf: Remove the removed irda feature from a comment
      musl: Add TEMP_FAILURE_RETRY from glibc
      systemd: Disable idn properly for musl instead of NI_IDN workarounds
      ofono: upgrade 1.25 -> 1.29

Alexander Kanavin (2):
      packagegroup-cross-canadian: repackage when TUNE_ARCH changes
      qemux86: use a Core 2 Duo CPU instead of the original circa-1993 Pentium

Fabio Berton (1):
      mesa: Convert recipe to use meson build system

Haiqing Bai (1):
      sysstat: Add PACKAGECONFIG[cron] for '--enable-install-cron' option

Khem Raj (2):
      mmc-utils: Fix build with clang
      epiphany: Do not bypass initialization of variable with __attribute__((cleanup))

Liwei Song (1):
      mdadm: install the systemd service through Makefile

Marco Felsch (1):
      mesa: fix imx gallium driver PACKAGECONFIG option

Mark Hatle (1):
      bitbake: gitsm: Fix a bug where the wrong path was used for the submodule init

Martin Jansa (2):
      grub-efi-cfg, systemd-boot-cfg: use MACHINE_ARCH
      tcmode-default.inc: use the same TUNE_PKGARCH variable as PN set in go-cross

Ming Liu (2):
      kernel.bbclass: adjust a condition checking
      dhcp: fix a NSUPDATE compiling issue

Richard Purdie (2):
      gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
      apr/apr-util: Add ptest dependency on libgcc

Ross Burton (1):
      glib-2.0: add missing libgcc dependency to glib-2.0-ptest

Tim Orling (1):
      libtest-needs-perl: upgrade 0.002005 -> 0.002006

Zang Ruochen (1):
      libinput: Upgrade 1.13.1 -> 1.13.2

Change-Id: Ic565210b5ca776c937445934910f602f424ecce1
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/recipes-core/systemd/systemd_242.bb b/poky/meta/recipes-core/systemd/systemd_242.bb
index 73e03c7..20714fc 100644
--- a/poky/meta/recipes-core/systemd/systemd_242.bb
+++ b/poky/meta/recipes-core/systemd/systemd_242.bb
@@ -36,7 +36,6 @@
                file://0006-Include-netinet-if_ether.h.patch \
                file://0007-don-t-fail-if-GLOB_BRACE-and-GLOB_ALTDIRFUNC-is-not.patch \
                file://0008-add-missing-FTW_-macros-for-musl.patch \
-               file://0009-socket-util-don-t-fail-if-libc-doesn-t-support-IDN.patch \
                file://0010-fix-missing-of-__register_atfork-for-non-glibc-build.patch \
                file://0011-Use-uintmax_t-for-handling-rlim_t.patch \
                file://0012-fix-missing-ULONG_LONG_MAX-definition-in-case-of-mus.patch \
@@ -71,6 +70,7 @@
     gshadow \
     hibernate \
     hostnamed \
+    idn \
     ima \
     kmod \
     localed \
@@ -95,6 +95,7 @@
 
 PACKAGECONFIG_remove_libc-musl = " \
     gshadow \
+    idn \
     localed \
     myhostname \
     nss \
@@ -129,6 +130,7 @@
 PACKAGECONFIG[gshadow] = "-Dgshadow=true,-Dgshadow=false"
 PACKAGECONFIG[hibernate] = "-Dhibernate=true,-Dhibernate=false"
 PACKAGECONFIG[hostnamed] = "-Dhostnamed=true,-Dhostnamed=false"
+PACKAGECONFIG[idn] = "-Didn=true,-Didn=false"
 PACKAGECONFIG[ima] = "-Dima=true,-Dima=false"
 # importd requires curl/xz/zlib/bzip2/gcrypt
 PACKAGECONFIG[importd] = "-Dimportd=true,-Dimportd=false"