poky: subtree update:a015ed7704..797916f93a

Adrian Bunk (4):
      poky-tiny.conf: Remove the removed irda feature from a comment
      musl: Add TEMP_FAILURE_RETRY from glibc
      systemd: Disable idn properly for musl instead of NI_IDN workarounds
      ofono: upgrade 1.25 -> 1.29

Alexander Kanavin (2):
      packagegroup-cross-canadian: repackage when TUNE_ARCH changes
      qemux86: use a Core 2 Duo CPU instead of the original circa-1993 Pentium

Fabio Berton (1):
      mesa: Convert recipe to use meson build system

Haiqing Bai (1):
      sysstat: Add PACKAGECONFIG[cron] for '--enable-install-cron' option

Khem Raj (2):
      mmc-utils: Fix build with clang
      epiphany: Do not bypass initialization of variable with __attribute__((cleanup))

Liwei Song (1):
      mdadm: install the systemd service through Makefile

Marco Felsch (1):
      mesa: fix imx gallium driver PACKAGECONFIG option

Mark Hatle (1):
      bitbake: gitsm: Fix a bug where the wrong path was used for the submodule init

Martin Jansa (2):
      grub-efi-cfg, systemd-boot-cfg: use MACHINE_ARCH
      tcmode-default.inc: use the same TUNE_PKGARCH variable as PN set in go-cross

Ming Liu (2):
      kernel.bbclass: adjust a condition checking
      dhcp: fix a NSUPDATE compiling issue

Richard Purdie (2):
      gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
      apr/apr-util: Add ptest dependency on libgcc

Ross Burton (1):
      glib-2.0: add missing libgcc dependency to glib-2.0-ptest

Tim Orling (1):
      libtest-needs-perl: upgrade 0.002005 -> 0.002006

Zang Ruochen (1):
      libinput: Upgrade 1.13.1 -> 1.13.2

Change-Id: Ic565210b5ca776c937445934910f602f424ecce1
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb b/poky/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb
new file mode 100644
index 0000000..3abb9aa
--- /dev/null
+++ b/poky/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Skip tests when modules not available"
+DESCRIPTION = "Skip test scripts if modules are not available. \
+The requested modules will be loaded, and optionally have their versions \
+checked. If the module is missing, the test script will be skipped. Modules \
+that are found but fail to compile will exit with an error rather than skip."
+
+HOMEPAGE = "https://metacpan.org/release/Test-Needs"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+CPAN_NAME = "Test-Needs"
+CPAN_AUTHOR = "HAARG"
+
+LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89"
+
+DEPENDS += "perl"
+
+SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "d5c96d51d8d5510f7c0b7f354c49af1c"
+SRC_URI[sha256sum] = "77f9fff0c96c5e09f34d0416b3533c3319f7cd0bb1f7fe8f8072ad59f433f0e5"
+
+S = "${WORKDIR}/${CPAN_NAME}-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN}-ptest += "perl-module-test-more"
+
+BBCLASSEXTEND = "native"