Squashed 'import-layers/meta-raspberrypi/' changes from cce6292e414..2a192261a91

Yocto 2.2.2 (Morty)

Change-Id: I96e39defae033e9f458f7c38a3b67296d6b3060f
git-subtree-dir: import-layers/meta-raspberrypi
git-subtree-split: 2a192261a914892019f4f428d7462bb3c585ebac
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/import-layers/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bb b/import-layers/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bb
index dcca369..074f448 100644
--- a/import-layers/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bb
+++ b/import-layers/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bb
@@ -1,9 +1,13 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
 
-LINUX_VERSION ?= "4.9.10"
+LINUX_VERSION ?= "4.9.27"
 
-SRCREV = "095c4480e1f623bdc8a221a171ef13b2223706b1"
+SRCREV = "9a5f215eda12bad29b35040dff00d0346fe517e2"
 SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=rpi-4.9.y \
-           file://0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch \
 "
 require linux-raspberrypi.inc
+
+# A LOADADDR is needed when building a uImage format kernel. This value is not
+# set by default in rpi-4.8.y and later branches so we need to provide it
+# manually. This value unused if KERNEL_IMAGETYPE is not uImage.
+KERNEL_EXTRA_ARGS += "LOADADDR=0x00008000"