systemd: set zstd as default PACKAGECONFIG

Upstream supports zstd compression now as an alternative to zlib or xz.
zstd is only slightly larger than xz but is significantly faster.  This
makes it a better candidate for the journal.  Enable it in systemd
instead of xz.

Add an exemption for witherspoon to continue using xz instead.  Having
both zstd and xz support built into the image puts us over the flash
limit and we currently need xz for phosphor-debug-collector.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I6fb55b96776aeeea1c544743b08bdbbc2853e7b7
diff --git a/meta-ibm/recipes-core/systemd/systemd_%.bbappend b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
index b61d930..354ea40 100644
--- a/meta-ibm/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
@@ -25,3 +25,9 @@
         install -m 644 -D ${WORKDIR}/systemd-journald-override.conf ${D}${systemd_system_unitdir}/systemd-journald.service.d/systemd-journald-override.conf
         install -m 644 -D ${WORKDIR}/journald-size-policy-16MB.conf ${D}${systemd_unitdir}/journald.conf.d/journald-size-policy.conf
 }
+
+# Witherspoon doesn't have the space for the both zstd and xz compression
+# libraries and currently phosphor-debug-collector is using xz.  Switch systemd
+# to use xz so only one of the two is added into the image.
+PACKAGECONFIG:remove:witherspoon = "zstd"
+PACKAGECONFIG:append:witherspoon = " xz"