Add virtual/phosphor-ipmi-sensor-inventory

This virtual provides a YAML file that serves as sensor
inventory configuration for phosphor-host-ipmid.

Add a native recipe that builds the configuration from MRW.
Set this recipe as the default for OpenPOWER systems.

Resolves openbmc/openbmc#781
Resolves openbmc/openbmc#1212

Change-Id: I25034dd3ed825e2ef320ab0b38ac2f733afded47
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index f90984f..3e33e9a 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -9,11 +9,15 @@
 inherit obmc-phosphor-license
 inherit obmc-phosphor-sdbus-service
 inherit obmc-phosphor-ipmiprovider-symlink
+inherit phosphor-ipmi-host
+inherit pythonnative
 
 DEPENDS += "phosphor-logging"
 DEPENDS += "phosphor-mapper"
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "packagegroup-obmc-ipmid-providers"
+DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
+
 RDEPENDS_${PN}-dev += "phosphor-logging"
 RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
 RDEPENDS_${PN} += "clear-once"
@@ -32,6 +36,7 @@
         "
 EXTRA_OECONF = " \
         WHITELIST_CONF="${WHITELIST_CONF}" \
+        SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
         "
 
 S = "${WORKDIR}/git"