ipmi: Add virtual/phosphor-ipmi-fru-hostfw-config

This virtual provides a configuration file that describes
host firmware implementation details to ipmi-fru-parser.

Add a recipe that provides the sample that comes with
ipmi-fru-parser.

Add a recipe for Hostboot on OpenPower systems.

Set the default provider to the example.

Set the default on OpenPOWER systems to the hostboot recipe.

Change-Id: Iff56c5c0c2ea8aec7ecaa5a5d981da6f88a894f2
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb
new file mode 100644
index 0000000..31aee2d
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Hostboot hostfw inventory map for phosphor-ipmi-fru"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-fru
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+        DEST=${D}${hostfw_datadir}
+
+        install -d ${DEST}
+        install config.yaml ${DEST}
+}