ipmi: Add virtual/phosphor-ipmi-fru-hostfw-config

This virtual provides a configuration file that describes
host firmware implementation details to ipmi-fru-parser.

Add a recipe that provides the sample that comes with
ipmi-fru-parser.

Add a recipe for Hostboot on OpenPower systems.

Set the default provider to the example.

Set the default on OpenPOWER systems to the hostboot recipe.

Change-Id: Iff56c5c0c2ea8aec7ecaa5a5d981da6f88a894f2
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
new file mode 100644
index 0000000..aca1d0a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Sample hostfw inventory map for phosphor-ipmi-fru"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+require phosphor-ipmi-fru.inc
+
+PROVIDES += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+        DEST=${D}${hostfw_datadir}
+        install -d ${DEST}
+
+        # TODO: copy example hostfw yaml to ${DEST}/config.yaml
+        # install fru-types.yaml ${DEST}/config.yaml
+}