meta-phosphor: classes: npcm8xx: fix image-u-boot didn't include merged files

Signed-off-by: Tim Lee <timlee660101@gmail.com>
Change-Id: I2d1ed130d2db71ba0ae4446a9380d7c9e8ad95fd
diff --git a/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass b/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass
index 93ff3e9..297db35 100644
--- a/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass
+++ b/meta-phosphor/classes/image_types_phosphor_nuvoton_npcm8xx.bbclass
@@ -9,9 +9,9 @@
 KMT_TIPFW_BB_UBOOT_BINARY = "u-boot.bin.merged"
 FULL_SUFFIX = "full"
 MERGED_SUFFIX = "merged"
+UBOOT_SUFFIX:append = ".${MERGED_SUFFIX}"
 
 IGPS_DIR = "${STAGING_DIR_NATIVE}/${datadir}/npcm8xx-igps"
-inherit logging
 
 # Prepare the Bootblock and U-Boot images using npcm8xx-bingo
 do_prepare_bootloaders() {
@@ -84,6 +84,7 @@
 do_prepare_bootloaders[depends] += " \
     npcm8xx-tip-fw:do_deploy \
     npcm8xx-bootblock:do_deploy \
+    u-boot-nuvoton:do_deploy \
     trusted-firmware-a:do_deploy \
     optee-os:do_deploy \
     npcm7xx-bingo-native:do_populate_sysroot \