sensors:max31785-msl: Make max31785-msl package be "opt-in"

By default, the max31785-msl package was getting installed in all images
including phosphor-hwmon. A fix was done in the phosphor-hwmon repo to
make this be an "opt-in" configure option to install the max31785-msl
application. This makes the max31785-msl a package config on the
phosphor-hwmon recipe where its not included unless explicitly appended
in a bbappend file in a machine layer.

ex.)
PACKAGECONFIG_append_ibm-ac-server = " max31785-msl"
SYSTEMD_ENVIRONMENT_FILE_max31785-msl_append_ibm-ac-server = " obmc/hwmon-max31785/max31785.conf"
SYSTEMD_LINK_max31785-msl_append_ibm-ac-server = " ../phosphor-max31785-msl@.service:multi-user.target.wants/phosphor-max31785-msl@${MACHINE}.service"

Tested:
    Built image without appending the max31785-msl package
      Verified no files related to it were in the image
    Build image appending the max31785-msl package
      Verified all related files were in the image

(From meta-phosphor rev: 22546d9032e077cddd4cef325080315e51720016)

Change-Id: Iacd8e4194f4749b023463965514ff6f73beb4739
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
index 5c98e74..de7c025 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -8,11 +8,17 @@
 inherit autotools pkgconfig
 inherit obmc-phosphor-systemd
 
+PACKAGECONFIG ??= ""
+# Autotools configure option to enable/disable max31785-msl
+PACKAGECONFIG[max31785-msl] = "--enable-max31785-msl, --disable-max31785-msl"
+# Meson configure option to enable/disable max31785-msl
+# PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl=false"
+
 PACKAGE_BEFORE_PN = "max31785-msl"
 SYSTEMD_PACKAGES = "${PN} max31785-msl"
 
 SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
-SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
+SYSTEMD_SERVICE_max31785-msl = "${@bb.utils.contains('PACKAGECONFIG', 'max31785-msl', 'phosphor-max31785-msl@.service', '', d)}"
 
 DEPENDS += "autoconf-archive-native"
 DEPENDS += " \