meta-facebook: Add License file for fb-powerctrl

fb-powerctrl: Added missing License file and also updated inheriting
obmc-phosphor-systemd instead of systemd file for installing service
files.

Tested: Build tiogapass image and verified.

(From meta-facebook rev: 4855da8a80b24c732ac77ba527ce4320186e1fa3)

Change-Id: I0508e4db25abfdbdb53f632069ffc619195ea883
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb b/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb
index 37fa835..a46c44b 100644
--- a/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb
+++ b/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb
@@ -1,6 +1,8 @@
 FILESEXTRAPATHS_append := "${THISDIR}/files:"
 
-inherit systemd
+inherit obmc-phosphor-systemd
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a8328fd2a610bf4527feedcaa3ae3d14"
 
 S = "${WORKDIR}/"
 
@@ -8,7 +10,8 @@
            file://power-util \
            file://host-gpio.service \
            file://host-poweroff.service \
-           file://host-poweron.service"
+           file://host-poweron.service \
+           file://LICENSE"
 
 DEPENDS = "systemd"
 RDEPENDS_${PN} = "bash"