openssl: run 'make depend'

The configure flags we have require openssl to be built with:
    make depend && make
The current openssl.inc file only has 'make', so prepend a call
to 'make depend'.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend b/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend
index a18a552..5816aef 100644
--- a/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend
+++ b/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend
@@ -1,3 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append = "file://Configure.patch"
 
 # General config settings.
 EXTRA_OECONF_append = " shared no-hw no-err no-psk no-srp no-engines "
@@ -9,3 +11,7 @@
 EXTRA_OECONF_append = " no-idea no-md2 no-mdc2 no-rc5 no-md4 \
         no-ripemd160 no-rmd160 no-whirlpool no-sha0 no-camellia \
         no-rc2 no-rc4 no-bf no-cast no-seed no-gost "
+
+do_configure_append() {
+    oe_runmake depend
+}