meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440

Chris Laplante (8):
      python3-adafruit-blinka: add recipe
      python3-adafruit-circuitpython-busdevice: add recipe
      python3-adafruit-circuitpython-motor: add recipe
      python3-adafruit-circuitpython-motorkit: add recipe
      python3-adafruit-circuitpython-pca9685: add recipe
      python3-adafruit-circuitpython-register: add recipe
      python3-adafruit-platformdetect: add recipe
      python3-adafruit-pureio: add recipe

Jose Quaresma (3):
      gstreamer1.0-omx: drop custom cflags
      gstreamer1.0-omx: consolidate the append usage and only use one
      gstreamer1.0-omx: drop config-files-path.patch

Khem Raj (2):
      python3-adafruit-blinka: Make rpi-gpio dependency conditional
      python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines

Martin Jansa (2):
      sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB
      sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID

Mike Looijmans (1):
      overlays: Add "vc4-kms-dsi-7inch.dtbo"

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
diff --git a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
index 0ae98cd..e803a0d 100644
--- a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
+++ b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
@@ -13,14 +13,14 @@
 #                                                     Default Free space = 1.3x
 #                                                     Use IMAGE_OVERHEAD_FACTOR to add more space
 #                                                     <--------->
-#            4MiB              40MiB           SDIMG_ROOTFS
+#            4MiB              48MiB           SDIMG_ROOTFS
 # <-----------------------> <----------> <---------------------->
 #  ------------------------ ------------ ------------------------
 # | IMAGE_ROOTFS_ALIGNMENT | BOOT_SPACE | ROOTFS_SIZE            |
 #  ------------------------ ------------ ------------------------
 # ^                        ^            ^                        ^
 # |                        |            |                        |
-# 0                      4MiB     4MiB + 40MiB       4MiB + 40Mib + SDIMG_ROOTFS
+# 0                      4MiB     4MiB + 48MiB       4MiB + 48Mib + SDIMG_ROOTFS
 
 # This image depends on the rootfs image
 IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
@@ -31,10 +31,12 @@
 SDIMG_KERNELIMAGE_raspberrypi3-64 ?= "kernel8.img"
 
 # Boot partition volume id
-BOOTDD_VOLUME_ID ?= "${MACHINE}"
+# Shorten raspberrypi to just rpi to keep it under 11 characters
+# now enforced by mkfs.vfat from dosfstools-4.2
+BOOTDD_VOLUME_ID ?= "${@d.getVar('MACHINE').replace('raspberrypi', 'rpi')}"
 
 # Boot partition size [in KiB] (will be rounded up to IMAGE_ROOTFS_ALIGNMENT)
-BOOT_SPACE ?= "40960"
+BOOT_SPACE ?= "49152"
 
 # Set alignment to 4MB [in KiB]
 IMAGE_ROOTFS_ALIGNMENT = "4096"