meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440

Chris Laplante (8):
      python3-adafruit-blinka: add recipe
      python3-adafruit-circuitpython-busdevice: add recipe
      python3-adafruit-circuitpython-motor: add recipe
      python3-adafruit-circuitpython-motorkit: add recipe
      python3-adafruit-circuitpython-pca9685: add recipe
      python3-adafruit-circuitpython-register: add recipe
      python3-adafruit-platformdetect: add recipe
      python3-adafruit-pureio: add recipe

Jose Quaresma (3):
      gstreamer1.0-omx: drop custom cflags
      gstreamer1.0-omx: consolidate the append usage and only use one
      gstreamer1.0-omx: drop config-files-path.patch

Khem Raj (2):
      python3-adafruit-blinka: Make rpi-gpio dependency conditional
      python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines

Martin Jansa (2):
      sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB
      sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID

Mike Looijmans (1):
      overlays: Add "vc4-kms-dsi-7inch.dtbo"

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
new file mode 100644
index 0000000..e05e2ab
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
@@ -0,0 +1,18 @@
+SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git"
+SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+    python3-adafruit-blinka \
+    python3-core \
+"