meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440

Chris Laplante (8):
      python3-adafruit-blinka: add recipe
      python3-adafruit-circuitpython-busdevice: add recipe
      python3-adafruit-circuitpython-motor: add recipe
      python3-adafruit-circuitpython-motorkit: add recipe
      python3-adafruit-circuitpython-pca9685: add recipe
      python3-adafruit-circuitpython-register: add recipe
      python3-adafruit-platformdetect: add recipe
      python3-adafruit-pureio: add recipe

Jose Quaresma (3):
      gstreamer1.0-omx: drop custom cflags
      gstreamer1.0-omx: consolidate the append usage and only use one
      gstreamer1.0-omx: drop config-files-path.patch

Khem Raj (2):
      python3-adafruit-blinka: Make rpi-gpio dependency conditional
      python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines

Martin Jansa (2):
      sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB
      sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID

Mike Looijmans (1):
      overlays: Add "vc4-kms-dsi-7inch.dtbo"

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
new file mode 100644
index 0000000..4454d24
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Platform detection for use by libraries like Adafruit-Blinka."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PlatformDetect"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fccd531dce4b989c05173925f0bbb76c"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PlatformDetect.git"
+SRCREV = "e0fe1b012898fa824944d6805ca74be0fa027968"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += "python3-core"