Move phosphor overrides of systemd into own recipe

Phosphor specific overrides to systemd should be stored
within its own recipe and pulled in via the phosphor layer.
This helps distinguish systemd specific overrides with
phosphor overrides.

Tested: Verified service-restart-policy.conf was still
pulled in as expected in witherspoon QEMU

Change-Id: I32110fc2edd3abd2bb0008c63dd4ad7828b762b8
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb b/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
new file mode 100644
index 0000000..34abf50
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor systemd configuration overrides"
+DESCRIPTION = "Overrides for systemd and its applications"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+DEPENDS += "systemd"
+
+SRC_URI = "file://service-restart-policy.conf"
+FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
+
+do_install() {
+        install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
+}