meta-phosphor: webui-vue: set inherit python3native

With a Yocto subtree update we started seeing webui-vue fail and during
investigation, I noticed that it was using the host Python instead of
the Yocto Python.
```
13:52:14 | npm ERR! gyp info find Python using Python version 3.10.12 found at "/var/jenkins-openbmc/workspace/ci-openbmc/distro/ubuntu/label/docker-builder/target/p10bmc/build/hosttools/python3"
```

There are Yocto patches to npm that anticipate we are using the Yocto
one, so we need to `inherit python3native`.

Change-Id: Ifbfc0a2358e561ddffe892010e45050761d7ac4a
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index 225fdb5..7ef77cb 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -21,6 +21,11 @@
 
 inherit allarch
 
+# Ideally this recipe would use npm.bbclass, but it doesn't.  Since npm uses
+# python3, we need to inherit this to get the Yocto version of python3 instead
+# of the hosttools one.
+inherit python3native
+
 RDEPENDS:${PN}:append = " bmcweb"
 
 EXTRA_OENPM ?= ""