meta-yadro: os-release: Add vendor/product info

Update the os-release generation script to set the welcome
string and the version according to the product name, branch name,
and vendor tags for all YADRO products.

(From meta-yadro rev: 5d28cfe0b0de03abd61707a013e63087e7ad18fd)

Signed-off-by: Alexander Amelkin <a.amelkin@yadro.com>
Change-Id: Ib8b6fd3d252c974fa3cdd2a703480dbd43cc9e0b
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/recipes-core/base-files/base-files%.bbappend b/meta-yadro/recipes-core/base-files/base-files%.bbappend
new file mode 100644
index 0000000..48c80e9
--- /dev/null
+++ b/meta-yadro/recipes-core/base-files/base-files%.bbappend
@@ -0,0 +1,7 @@
+do_install_basefilesissue () {
+	if [ "${hostname}" ]; then
+		echo ${hostname} > ${D}${sysconfdir}/hostname
+	fi
+
+	# Issue files are provided by os-release recipe instead
+}