ipmi-whitelist: fix compile issue

ipmi-whitelists were not working correctly when restored from sstate
due to incorrect path locations in the bbclass.  Files being installed
with the do_install step were not associated with the package because
they were placed in the wrong directory.  By placing in the right
directory, they are placed into the sstate file and restored correctly.

The files were also installed into /etc and move to /usr/share.  This
matches what is being done for the mrw files (see
phosphor-ipmi-fru.bbclass for example).

Change-Id: I1881d383d4d9d7d3098411fa83c85e49c3a08560
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index 641aa4d..2b40065 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -27,7 +27,7 @@
 
 # Setup IPMI Whitelist Conf files
 WHITELIST_CONF = " \
-        ${STAGING_ETCDIR_NATIVE}/phosphor-ipmi-host/*.conf \
+        ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
         ${S}/host-ipmid-whitelist.conf \
         "
 EXTRA_OECONF = " \