meta-phosphor: Fix explicit dependencies antipattern

Out of the box bitbake examines built applications, automatically adds
runtime dependencies and thus ensures any library packages dependencies
are automatically added to images, sdks, etc.  There is no need to list
them explicitly in a recipe.

Dependencies change over time, and listing them explicitly is likely
prone to errors - the net effect being unnecessary shared library
packages being installed into images.

Consult
https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#var-RDEPENDS
for information on when to use explicit runtime dependencies.

(From meta-phosphor rev: 26873c99d30b55e21a920c9851f21c3e2eab19f7)

Change-Id: I38640d75a2d834c07d45ddcdb0162f1a23f848d9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb
index 91511b2..60b6761 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb
@@ -11,8 +11,8 @@
 
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "sdbusplus"
+DEPENDS += "systemd"
 DEPENDS += "phosphor-dbus-interfaces"
-RDEPENDS_${PN} += "libsystemd"
 
 DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service"