Add fb-powerctrl to Facebook Tiogapass

Added a new module fb-powerctrl to comtrol host power. It
includes power-util which controls power on and off of
given host server.

Tested: Build Facebook TiogaPass board and load on the
target hardware. Ensured that power on and off features
works as expected.

(From meta-facebook rev: 67abf96e04c1aab15c90480eca2b00bf9b5c51ab)

Change-Id: I21090bbe461111c15e404c544f303615fbf62c9b
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb b/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb
new file mode 100644
index 0000000..37fa835
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-fbtp/fb-powerctrl/fb-powerctrl.bb
@@ -0,0 +1,23 @@
+FILESEXTRAPATHS_append := "${THISDIR}/files:"
+
+inherit systemd
+
+S = "${WORKDIR}/"
+
+SRC_URI = "file://setup_gpio.sh \
+           file://power-util \
+           file://host-gpio.service \
+           file://host-poweroff.service \
+           file://host-poweron.service"
+
+DEPENDS = "systemd"
+RDEPENDS_${PN} = "bash"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
+
+do_install() {
+    install -d ${D}/usr/sbin
+    install -m 0755 ${S}setup_gpio.sh ${D}/${sbindir}/
+    install -m 0755 ${S}power-util ${D}/${sbindir}/
+}