systemd: Configure shutdown watchdog to 20min

There were reports of the shutdown watchdog firing in #522 which caused
the flashing process to fail. Andrew Geissler suggested he reached ~77%
before the watchdog bit, which by default is configured at 10 minutes.
Back-of-the-envelope calculations suggest it would've taken
approximately 13 minutes to complete the flash, therefore bump the
number to 20min to give ourselves a bit of head-room.

Change-Id: I967b13799469d22a380b29f5566ab8cc9432ce8c
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index a93de86..5cc25db 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -6,16 +6,19 @@
                         quotacheck kdbus ima smack polkit logind bootchart utmp"
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 SRC_URI += "file://default.network"
+SRC_URI += "file://shutdown-watchdog.conf"
 SRC_URI += "file://0001-Export-message_append_cmdline.patch"
 SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
 
 RRECOMMENDS_${PN} += "obmc-targets"
 FILES_${PN} += "${libdir}/systemd/network/default.network"
+FILES_${PN} += "${libdir}/systemd/system.conf.d/shutdown-watchdog.conf"
 
 EXTRA_OECONF += " --disable-hwdb"
 
 do_install_append() {
         install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
+        install -m 644 -D ${WORKDIR}/shutdown-watchdog.conf ${D}${libdir}/systemd/system.conf.d/shutdown-watchdog.conf
 
         #TODO Remove after this issue is resolved
         #https://github.com/openbmc/openbmc/issues/152