fans: Add missing evdev dependency

The fan repository depends on libevdev unconditionally now.

Change-Id: I5cbddcb865ab9782e7556de83df05076c3f520b7
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
index fd07908..b28271b 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
@@ -17,6 +17,7 @@
 DEPENDS += "python-mako-native"
 DEPENDS += "sdbusplus"
 DEPENDS += "phosphor-logging"
+DEPENDS += "libevdev"
 
 # Package configuration
 FAN_PACKAGES = " \
@@ -108,4 +109,4 @@
 
 # --------------------------------------
 # phosphor-cooling-type specific configuration
-PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,libevdev,"
+PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,,"