gtest: update to 1.8.1

Update to 1.8.1, which has proper pkg-config support (so
Add-pkg-config-support.patch can be dropped).

Also the canonical gtest seems to have moved out of the google github
organization into something called abseil.  Update HOMEPAGE and SRC_URI
to match.

(From meta-openembedded rev: 179a1b9ea86f33b5a3f4eec9fcc00c0a5e8833f0)

Change-Id: Ifcc8d8b4d008be5becaba819983e04f4a9752be6
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-test/gtest/gtest_1.8.1.bb b/meta-openembedded/meta-oe/recipes-test/gtest/gtest_1.8.1.bb
new file mode 100644
index 0000000..23862c9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/gtest/gtest_1.8.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Google's framework for writing C++ tests"
+HOMEPAGE = "https://github.com/abseil/googletest"
+SECTION = "libs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
+                    file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
+
+PROVIDES += "gmock"
+
+S = "${WORKDIR}/git"
+SRCREV = "2fe3bd994b3189899d93f1d5a881e725e046fdc2"
+SRC_URI = "\
+    git://github.com/abseil/googletest.git;protocol=https; \
+"
+
+inherit cmake
+
+ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY_${PN}-dbg = "1"
+
+RDEPENDS_${PN}-dev += "${PN}-staticdev"
+
+BBCLASSEXTEND = "native nativesdk"