Software.BMC.Updater: Add dependency to op-vpd-parser

The BMC updater service searches for the BMC inventory object to
create a version association. The BMC object is created by the
op-vpd-parser, so waiting for this service ensures that the BMC
object is present when the BMC updater service starts.

Add this dependency via a systemd override since the op-vpd-parser
is an openpower package. Witherspoon is the only system that
currently includes this package.

Resolves openbmc/openbmc#2698
Resolves openbmc/openbmc#2494

Change-Id: I869ec8717a6bf22a1f0da19167eb0f186c05014e
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/phosphor-software-manager.bbappend b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/phosphor-software-manager.bbappend
new file mode 100644
index 0000000..c1799f1
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/phosphor-software-manager.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+
+SYSTEMD_OVERRIDE_${PN}-updater += \
+    "software-bmc-updater.conf:xyz.openbmc_project.Software.BMC.Updater.service.d/software-bmc-updater.conf"