Revert "poky: subtree update:b23aa6b753..ad30a6d470"

This reverts commit af5e4ef732faedf66c6dc1756432e9de2ac72988.

This commit introduced openbmc/openbmc#3720 and no solution has been
forthcoming. Revert until we can get to the bottom of this.

Change-Id: I2fb0d81eb26cf3dadb2f2abdd1a1bb7a95eaf03c
diff --git a/poky/meta/recipes-support/boost/bjam-native_1.74.0.bb b/poky/meta/recipes-support/boost/bjam-native_1.74.0.bb
new file mode 100644
index 0000000..d843eb0
--- /dev/null
+++ b/poky/meta/recipes-support/boost/bjam-native_1.74.0.bb
@@ -0,0 +1,20 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
+            file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
+           "
+
+do_compile() {
+    ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+    install -d ${D}${bindir}/
+    # install unstripped version for bjam
+    install -c -m 755 b2 ${D}${bindir}/bjam
+}