Address build break on RHEL

In older versions of coreutils install with -D and -t together has
different behavior such that the destination directory is not created.
Later versions of coreutils this does work but manually install the
target directory so builds on RHEL7 can work.

Change-Id: I42c46198321e4bf8085898b6d7485a3425634aca
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/devtools/obmc-pydevtools.bb b/meta-phosphor/common/recipes-phosphor/devtools/obmc-pydevtools.bb
index 70fad63..b8911aa 100644
--- a/meta-phosphor/common/recipes-phosphor/devtools/obmc-pydevtools.bb
+++ b/meta-phosphor/common/recipes-phosphor/devtools/obmc-pydevtools.bb
@@ -19,6 +19,7 @@
 do_install_append() {
 	if [ -f ${S}/obmcutil-completion.sh ]
 	then
-		install -m 0644 -D -t ${D}/${sysconfdir}/profile.d ${S}/obmcutil-completion.sh
+		install -d ${D}${sysconfdir}/profile.d
+		install -m 0644 -D -t ${D}${sysconfdir}/profile.d ${S}/obmcutil-completion.sh
 	fi
 }