meta-security: subtree update:6d399b34ab..30ea7a89dc

Adrian Bunk (2):
      xmlsec1: Remove, moved to meta-oe
      libenv-perl: Remove, moved to meta-perl

Armin Kuster (3):
      apparmor: fix RDPENDS
      apparmor: update to 2.13.3
      integrity-image: IMA_EVM_KEY_DIR has no affect, remove

Qi.Chen@windriver.com (2):
      ecryptfs-utils: remove openssl PACKAGECONFIG
      ecryptfs-utils: fix race condition in do_install

Yuan Chao (2):
      python-scapy: upgrade 2.4.2 -> 2.4.3
      checksec: upgrade 1.11.1 -> 2.1.0

Change-Id: I888703dc3a3df6fa0da471e1d112f9d88dcdc44b
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-security/recipes-security/checksec/checksec_2.1.0.bb b/meta-security/recipes-security/checksec/checksec_2.1.0.bb
new file mode 100644
index 0000000..5c6528e
--- /dev/null
+++ b/meta-security/recipes-security/checksec/checksec_2.1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Linux system security checks"
+DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
+SECTION = "security"
+LICENSE = "BSD"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a"
+
+SRCREV = "04582bad41589ad479ca8b1f0170ed317475b5a5"
+SRC_URI = "git://github.com/slimm609/checksec.sh"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${S}/checksec ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "bash openssl-bin"