bmcweb: add mutual-tls-auth PACAKGECONFIG

meta-ibm already overrides this meson setting in some cases.  Promote it
to a PACKAGECONFIG so it is clearer as to which machines have it enabled
and which have it disabled.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I198d2ac1f403317f0eaf4ee2a348da87707d8820
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index c444202..a61a14a 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -28,8 +28,9 @@
 inherit useradd
 inherit pkgconfig meson ptest
 
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "mutual-tls-auth"
 PACKAGECONFIG[insecure-redfish-expand]="-Dinsecure-enable-redfish-query=enabled"
+PACKAGECONFIG[mutual-tls-auth]="-Dmutual-tls-auth=enabled,-Dmutual-tls-auth=disabled"
 
 EXTRA_OEMESON = " \
     --buildtype=minsize \