meta-phosphor: jsnbd: promote dynamic-layers content

The previous 'dynamic-layers' content has been fixed so that it is
functional on both aspeed and nuvoton (and likely any system that
exposes the same sysfs class entries).  Promote this content out
of dynamic-layers and make it common to reduce the hardware-specific
duplication.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I8f8247098ef8f8b035269815ebe77dedb2e8a441
diff --git a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
index 4b6cd33..6a119dd 100644
--- a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
+++ b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -8,7 +8,10 @@
 PV = "1.0+git${SRCPV}"
 PR = "r1"
 
-SRC_URI = "git://github.com/openbmc/jsnbd;branch=master;protocol=https"
+SRC_URI = "\ 
+    git://github.com/openbmc/jsnbd;branch=master;protocol=https \
+    file://state_hook \
+    "
 
 S = "${WORKDIR}/git"
 
@@ -17,8 +20,11 @@
 do_install:append() {
     install -d ${D}${sysconfdir}/nbd-proxy/
     install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
+    install -m 0755 ${WORKDIR}/state_hook ${D}${sysconfdir}/nbd-proxy/state
 }
 
+FILES:${PN} += "${sysconfdir}/nbd-proxy/state"
+
 RDEPENDS:${PN} += "nbd-client"
 
 NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"