class: obmc-phosphor-ipmiprovider-symlink: Add IPMI Blobs

The IPMI Blobs handler is loaded by phosphor-host-ipmid at run-time, and
this handler then searches for IPMI Blob Handlers.  This patch adds the
option to register them against this class and installs a symlink to
blob handlers in a location expected by the blob manager.  This is akin
to what's presently done for phosphor-host-ipmid and phosphor-net-ipmid.

(From meta-phosphor rev: 4b3f25f6d43caa08e4f424d875c46212727f0d08)

Change-Id: Ied2b1adf85ec9510c119f9b79367a284ad376751
Signed-off-by: Patrick Venture <venture@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass b/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass
index 7a86496..a025b42 100644
--- a/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass
@@ -2,9 +2,14 @@
 
 inherit obmc-phosphor-utils
 
+# This LIBDIR is searched for the libraries.
 LIBDIR = "${D}/${libdir}/ipmid-providers/"
+
+# The symlinks are installed in the following directories depending on the
+# variable.
 HOSTIPMI_LIBDIR = "${D}/${libdir}/host-ipmid/"
 NETIPMI_LIBDIR = "${D}/${libdir}/net-ipmid/"
+BLOBIPMI_LIBDIR = "${D}/${libdir}/blob-ipmid/"
 
 python symlink_create_postinstall() {
     def install_symlink(d, libname, install_dir):
@@ -34,5 +39,9 @@
     for libname in listvar_to_list(d, 'NETIPMI_PROVIDER_LIBRARY'):
         install_dir = d.getVar('NETIPMI_LIBDIR', True)
         install_symlink(d, libname, install_dir)
+
+    for libname in listvar_to_list(d, 'BLOBIPMI_PROVIDER_LIBRARY'):
+        install_dir = d.getVar('BLOBIPMI_LIBDIR', True)
+        install_symlink(d, libname, install_dir)
 }
 do_install[postfuncs] += "symlink_create_postinstall"