nicole: Add VPD support

VPD contains general description of the BMC card and MAC address for
the Ethernet controller.
Physically, VPD is stored in the EEPROM AT24C256C, which is connected
to the Aspeed SoC via I2C and can be read or written through
the special device file /sys/bus/i2c/devices/0-0050/eeprom.

(From meta-yadro rev: 95f98dc7d5ccf2b221d2a5aea51bf411201f351c)

Signed-off-by: Artem Senichev <a.senichev@yadro.com>
Change-Id: I21624f154cfa1e92eddbc1739a4e053d00889b5a
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/vpd/nicole-openpower-fru-properties-native.bb b/meta-yadro/meta-nicole/recipes-phosphor/vpd/nicole-openpower-fru-properties-native.bb
new file mode 100644
index 0000000..05be1df
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/vpd/nicole-openpower-fru-properties-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "FRU properties config for openpower-vpd-parser"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+inherit openpower-fru-vpd
+
+SRC_URI += "file://properties.yaml"
+
+PROVIDES += "virtual/openpower-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+        DEST=${D}${properties_datadir}
+        install -d ${DEST}
+        install properties.yaml ${DEST}/out.yaml
+}