op-proc-control: bmc reset host status check

Enable the new BMC function to look at a CFAM register as a last chance
to see if the host is running.

See the following for more detail:
https://github.com/openbmc/docs/blob/master/designs/bmc-reset-with-host-up.md#note-on-custom-mechanism-for-ibm-systems

openpower-proc-control: srcrev bump f8c14bcfd5..3292c0676e

Andrew Geissler (8):
      service-files: move to own sub-directory
      primary-proc: move function to common utils
      bmc-reset: check if host is running
      bmc-reset: ensure error is created if host up
      bmc-reset: call new host reset check service
      bmc-reset: add support to write a cfam
      bmc-reset: add support to clear host running register
      bmc-reset: call new clear host running status service

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If4f7c3a7a58bbe5c7fda09bdc949ed31f5cb1cbf
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 7ce65f9..c0132b8 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -57,6 +57,10 @@
 		LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
 		TARGET="../proc-pre-poweroff@.service"
 		ln -s $TARGET $LINK
+
+		LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
+		TARGET="../op-reset-host-check@.service"
+		ln -s $TARGET $LINK
     fi
 
 	# If the memory preserving reboot feature is enabled, set it up