Revert "Remove dependency on phosphor-ipmi-inventory-sel recipe."

This reverts commit 2b8dbf0eb056e6aa05749563b02e931c656a4496.

This commit is reverted because the mapping of D-Bus object path to
sensor information is needed to service the SEL commands which translate
D-Bus logging objects to SEL entries. This dependency can be removed once the
SEL moves to the journal and there will be no mapping between logging objects
and SEL entries.

(From meta-phosphor rev: c32034f776bafa9957c8af22769e5707508f6013)

Change-Id: I927014cfc109bc34d673d62591890a233e29f3c5
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 67cdf37..45dd98b 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -30,6 +30,7 @@
 DEPENDS += "phosphor-mapper"
 DEPENDS += "sdbusplus"
 DEPENDS += "sdbus++-native"
+DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
 DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
 DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
 DEPENDS += "virtual/phosphor-ipmi-channel-config"
@@ -73,6 +74,7 @@
 EXTRA_OECONF = " \
         WHITELIST_CONF="${WHITELIST_CONF}" \
         SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
+        INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
         FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
         CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
         POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\