Create a phosphor-specific initramfs

OpenBMC has been using a .bbappend to add/remove packages from
core-image-minimal-initramfs.  Doing so keeps the recipe and initramfs
image name as core-image-minimal-initramfs which is misleading as it now
is very much phosphor-specific.  Instead, make a new
obmc-phosphor-initramfs recipe and image that is patterned after
core-image-minimal-initramfs.

Change-Id: Ieca2268eff01bb61cc0d25a1cbc1a6f5fadb6d2c
Signed-off-by: Rick Altherr <raltherr@google.com>
diff --git a/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb
new file mode 100644
index 0000000..b68048a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
+first 'init' program more efficiently."
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "obmc-phosphor-initramfs"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"