meta-hpe: Update binary bootblock recipes for GXP

Update the build recipes for the GXP binary bootblock that runs before U-Boot.
The code has been restructured such that the DL360POC machine is the exception,
so this includes the overrides for the DL360POC.

Signed-off-by: Mike Garrett <mike.garrett@hpe.com>
Change-Id: I507a6e32c7c72613dbd1239824f528f0f60d1f6f
diff --git a/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass b/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass
new file mode 100644
index 0000000..bd69e16
--- /dev/null
+++ b/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass
@@ -0,0 +1,26 @@
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+# TODO:  Manually copy the U-Boot signing key and customer-key-block here:
+HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files"
+
+inherit deploy
+
+do_deploy () {
+  install -d ${DEPLOYDIR}
+
+  # Copy in the bootblock
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
+
+  # Copy in files from the files subdirectory
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section
+
+  # Copy in the U-Boot signing key
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem
+
+  # Copy in the customer keyblock
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block
+}
+
+addtask deploy before do_build after do_compile
+