phosphor-mapper: Add service namespaces

The c++ mapper implements a dbus service namespace whitelist instead of
a path namespace whitelist.  A service namespace whitelist significantly
reduces the amount of introspection required by the mapper as compared
to path namespaces.

Add the service namespace whitelist to the mapper command line in the
mapper systemd unit and extend the existing framework for specifying
mapper command line arguments to include a service namespace whitelist.

Note that support for a _service_ blacklist is added and _path_ and
_interface_ blacklists are not being re-introduced.

(From meta-phosphor rev: 385c63fee1d7ac4f34165de7095f2e76b10f1328)

Change-Id: I0cc8f7d7dd0c1196b2354118cf6ab89b2d30231f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/phosphor-mapperdir.bbclass b/meta-phosphor/classes/phosphor-mapperdir.bbclass
index 33962f2..ed68628 100644
--- a/meta-phosphor/classes/phosphor-mapperdir.bbclass
+++ b/meta-phosphor/classes/phosphor-mapperdir.bbclass
@@ -1,2 +1,4 @@
 namespace_dir="${datadir}/phosphor-mapper/namespace"
+service_dir="${datadir}/phosphor-mapper/service"
 interface_dir="${datadir}/phosphor-mapper/interface"
+serviceblacklist_dir="${datadir}/phosphor-mapper/serviceblacklist"