openpower: Remove fsi-bind service

A year ago I added support for the external mode sysfs file to use when
using cronus. This meant we did not need to un-bind the FSI driver. When
that change went in we also should have removed the now-unused fsi-bind
service.

Change-Id: Ief0c2362f30f4dd7c320bf904000fe11be6b4914
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/fsi/op-fsi.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/fsi/op-fsi.bb
index 5cb0053..840b649 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/fsi/op-fsi.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/fsi/op-fsi.bb
@@ -13,11 +13,6 @@
 INSTFMT_SCAN = "fsi-scan@{0}.service"
 FMT_SCAN = "../${TMPL_SCAN}:${TGTFMT}.requires/${INSTFMT_SCAN}"
 
-TMPL_BIND = "fsi-bind@.service"
-INSTFMT_BIND = "fsi-bind@{0}.service"
-FMT_BIND = "../${TMPL_BIND}:${TGTFMT}.requires/${INSTFMT_BIND}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} ${TMPL_BIND} fsi-enable.service fsi-disable.service"
+SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} fsi-enable.service fsi-disable.service"
 
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_BIND', 'OBMC_CHASSIS_INSTANCES')}"