sdbusplus: Add sdbus++ package in the usual manner

Prepending PACKAGES breaks bitbake virtclass variable remapping
of PACKAGES in native context.  This can leave more recent
versions of bitbake unable to find sdbusplus as an rprovider
of sdbus++-native.

Add sdbus++ to PACKAGES in the usual way, that is setting
PACKAGE_BEFORE_PN, which allows bitbake virtclass variable
remapping to work.

Tested: Built a witherspoon image with Rocko
Change-Id: I91f9c11714c5327b92ed8e2cc55239f967cd8d98
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb b/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
index 9fa95d6..cd83d7e 100644
--- a/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
+++ b/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
@@ -45,7 +45,7 @@
 S = "${WORKDIR}/git"
 
 PROVIDES_prepend = "sdbus++ "
-PACKAGES_prepend = "sdbus++ "
+PACKAGE_BEFORE_PN = "sdbus++"
 FILES_sdbus++_append = " ${bindir}/sdbus++"
 PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"